CU

Be sure to have at least JAVA 9 installed to run our newest launcher !!!
    1. Topic
    2. Replies
    3. Last Reply
    1. It is time for a change !

      • Undercova
    2. Replies
      0
      Views
      503
      0
    1. Star Wars Galaxies - An empire reworked /// Your input needed ! 177

      • Undercova
    2. Replies
      177
      Views
      10k
      177
    3. mad-macs

    1. Choose what is next ! 4

      • Undercova
    2. Replies
      4
      Views
      693
      4
    3. RiuJammer

    1. When will the CU 10

      • Skyyyr
      • Skyyyr
    2. Replies
      10
      Views
      2k
      10
    3. pcgoblin

    1. What's with the CU? 13

      • Htoob
    2. Replies
      13
      Views
      5.3k
      13
    3. Synge