Travel cost

  • Hi all,


    Played SWG from beta upto the end.
    Been following several emulators but thought that Project SWG was going to offer what I missed about the game.


    Have been a professional software engineer for the past 25 years, alot of code and alot of late nights 8|


    I setup a Linux server with the code and got that all running, but no matter what I try the game always want's money to travel to other zones. Am I misssing something.
    No of the Admin commands seem to work, other that making my player vanish, never to be seen again.


    Any ideas on setting travel costs to 0 or getting the Admin command working would be handy.


    Really want to get my teeth into helping with the task ahead, but I never liked Tatooine ^^


    Thanks in advance


    Farside - Elder Jedi
    Bria

  • There should be a file /cfg/features.cfg. In it, you can set/add:


    TICKET-PRICE-FACTOR=0


    Holocore will have to be rebooted for the change to take effect.


    As for the admin commands, I need to know what happens when you try to execute one (the actual error message would be great).

    xI45L74.png

  • Thank you for the speedy reply.
    I'll give that a try in a little while and I'll also get the error messge / s


    Thank you again Ziggy

  • /dumpzoneinformation


    "No such command, mood, chat type: dumpzoneinformation"


    /qatool recover ziet


    "No such command, mood, chat type: qatool"


    Not sure if these are valid, but read them in Undercova's post on Admin Commands.


    Thank you again

  • did you set your account to DEV or QA in pgAdmin ?


    if so ... then use the /setgodmode command first. THEN all the admin commands work

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • He may have to do that later, yes. For this specific problem, he actually needs to edit yet another config. This time, it's on the client.


    I've done this in login.cfg, but I think you can do it in user.cfg (empty by default) as well. Set 0fd345d9=true under [ClientGame].
    This will make the client load the admin commands from the command table.


    That portion of my login.cfg file looks like this:


    Code: login.cfg
    1. [ClientGame]
    2. loginServerAddress0=localhost
    3. loginServerPort0=44453
    4. 0fd345d9=true

    xI45L74.png

  • Set DEV no god mode, changed it to dev and it worked.


    Other commands still not functioning though.


    /qatool would be very handy.


    Thanks Undercov.


    Will give the login.cfg a go, thanks again Ziggy

  • It's a bit of a hassle to set all this up properly, sorry about that. We haven't looked too much into all the admin stuff yet.


    You're welcome. Let me know how it goes.

    xI45L74.png

  • That worked, thank you.


    Can go and play in the lava of Mustafar and have a go at fixing the co-ordinates.


    And no need to appologise, all part of the journey.


    Thanks guys

  • That worked, thank you.Can go and play in the lava of Mustafar and have a go at fixing the co-ordinates.And no need to appologise, all part of the journey.Thanks guys

    co-ordinates on mustafar were never broke, they used offset because mustafar wasnt a grid like this:


    q1 q2
    q4 q3


    rather:

    q1


    X