Login issues ? Try this

  • In case you encounter login issues plz check following:


    - Do you have latest version of our launcher downloaded and installed ?? Older versions WILL NOT WORK ! Look for the bottom left corner and the launcher will tell you if it is up to date or outdated.
    - Did you enter your exact forum name as username in the login details ?
    - Did you enter your exact forum password as password in the login details ?
    - Please try a more simple password like just numbers. Special letters do not work very well
    - Is your firewall blocking the game ?
    - make sure the launcher is able to communicate past your local firewall: technipages.com/blockunblock-programs-in-windows-firewall
    - if the above doesn't fix it, change your local port forwarding address in your router settings to the IP of your computer. Not the IP you login to your router to, but the one you can view via ipconfig: groovypost.com/howto/find-windows-10-device-ip-address/. Also make sure the port forwarding setting is for 44453 TCP - not UDP.
    - Check in your launcher settings if all is set correct


    - in case you have problems with your launcher not being able to update the local files please move the SWG installation folder to a non-admin area ( avoid C:/program files/.... )

    - moving the launcher.jar file to the desktop is also highly advised



    if you tried ALL of these feel free to contact us here in the support forum section

  • Current problem:


    Launcher updates to a new version and finishes the SCAN with UPDATE button

    Once you click that button it fails to download the resources


    Solution:

    • go though to your PSWG String folder (ie. C:\Program Files (x86)\ProjectSWG\string\en)
    • delete the Live_motd.stf file
    • restart launcher allow it to scan files.
    • once it finishes scan, Click update
    • when update is complete you should be able to play the game



    Thanks to Rowsdow3r for finding this solution

    Launcher update fail

  • I have not logged on for a few weeks, but I saw there was a new launcher, so I downloaded it and when thru the installation process. This morning I did my weekly scan using Malwarebytes and it detected the launcher as malware (trojan) and I had them removed via the quarantine and removal process. Of course, this means I can not launch the game. Anyone else having this issue and a possible work around

    Tks

  • I have not logged on for a few weeks, but I saw there was a new launcher, so I downloaded it and when thru the installation process. This morning I did my weekly scan using Malwarebytes and it detected the launcher as malware (trojan) and I had them removed via the quarantine and removal process. Of course, this means I can not launch the game. Anyone else having this issue and a possible work around

    Tks

    i only had a virus check at initial start ... took the app 15 secs to scan it .. then it got approved. all fine for me


    you will most likely have to set it on the whitelist

  • I took your suggestion and allowed the launcher thru the windows defender (“whitelist”) however took a few minutes and ran the scan via Malwarebytes and sure enough it detected the launcher as malware (trojan) but this time I did not quarantine the four noted files and when I got the message from Malwarebytes (what do you want to do with these files I choose “always ignore” and ran the scan again.

    This time Malwarebytes did not report the launcher as a threat

    Tks