local server help?

  • So I followed the readme.md file and made a couple educated guesses and happily got a server compiled and running..


    I edited the PSWG launchpad to use localhost instead of ProjectSWG of course, but am unsure how to create an account at this time to log in? Read through the posts here and no one mentions anything about how they created accounts. lol. Help?


    I did try blindly pointing to http://127.0.0.1 thinking maybe a mini webserver launches with the server but nothing there.

    I also tried randomly trying a username/pw to see if it would just let anyone on and that didn't work either..

    Though that's my second question, should the console for the server be showing connection attempts? Because mine didn't.. The last line is still (date/time) Started. Time: xxxxxx.ms

    Just wondering/thinking that it would be logging connection attempts and suspecting that this could be part of my problem other than not knowing how to get accounts in the system :)


    Please help :) thanks in advance..

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

  • Account creation is not documented at all. Sorry about that. What you need to do is sign in with the default credentials: holocore password


    Holocore has no webserver at this time, but that was an excellent guess.

    xI45L74.png

  • Could you tell me if the console for holocore should be telling me if there are any attempted connections? (IE ip xxx.xxx.xxx.xxx is connecting or is trying to connect or connection established, etc..?

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

  • Ok. Seems I've got more troubleshooting to do then. I haven't seen a single message on there other than that it's done loading :( This goes hand in hand with my login/launcher issue of getting onto your server as well. Hopefully when that problem is resolved this one will be too, then. (see other post if curious? lol)

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

  • the local server booted up fine ? It says "Started" in console ?

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • it should look like this


    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • This is the copy/paste of my console: (severely clipped due to character limit on post)

    Code
    1. 06-06-17 21:20:13.698 I: Created new resource 'wood_deciduous_rori 601' with ID 601 of type wood_deciduous_rori with 1 spawns per planet
    2. 06-06-17 21:20:13.698 I: Created new resource 'wood_deciduous_talus 602' with ID 602 of type wood_deciduous_talus with 1 spawns per planet
    3. 06-06-17 21:20:13.698 I: Created new resource 'wood_deciduous_tatooine 603' with ID 603 of type wood_deciduous_tatooine with 1 spawns per planet
    4. 06-06-17 21:20:13.698 I: Created new resource 'wood_deciduous_yavin4 604' with ID 604 of type wood_deciduous_yavin4 with 1 spawns per planet
    5. 06-06-17 21:20:13.736 I: Initialized. Time: 752321.761ms
    6. 06-06-17 21:20:13.737 I: Starting...
    7. 06-06-17 21:20:13.946 I: Started. Time: 752530.886ms

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

  • looks fine

    did you change your launcher to "localhost" then ?


    in this case i didnt boot up my local server ... in yours it should say SERVER STATUS: ONLINE then



    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • Yes I did change it to localhost, even tried to make my own with the IP referencing my LAN IP). Interestingly, when I do that, AND when I set it to localhost, it DOES show "SERVER STATUS: ONLINE"! So it CAN see the server, it just doesn't want to communicate with it. This parallels my problem with getting onto your server it would seem, though I don't know what that issue could be yet. ;( lol

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

  • When I enter the user/pass (holocore/password, but I could type anything, nothing makes a difference) the usual UI comes up and as connecting to the login server and it just hangs there (unable to connect to it, I assume).

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

  • When I enter the user/pass (holocore/password, but I could type anything, nothing makes a difference) the usual UI comes up and as connecting to the login server and it just hangs there (unable to connect to it, I assume).

    what does the server log say ?

    does it recognize your login attempt ?

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • If by log you mean the console, then no it doesn't log/show anything. My post up above (#8 in the thread) is how it still looks, and when I took that I had tried connecting about 10 times, now, even more. lol. For some reason the launcher doesn't seem to be working for me.

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

  • dont change the IP stuff or whatever. just select "localhost" in the server list in launcher.


    • boot up server
    • switch to localhost server in launcher
    • check if UP is showing up
    • start the game
    • enter details
    • check console for login attempt

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • Shutdown and restarted computer.

    Fired up PSWG Launcher and set login server to localhost.

    Verified Server Status: Down

    Started Server.

    Noted it says "Server Status Loading" (pretty cool that it does that, btw)

    Waited for server to finish loading.

    Noticed while server loading this:

    Code
    1. :48:33.762 E: Not saving 'odb\mails.db', file not loaded yet!
    2. 10-06-17 08:49:37.430 I: Finished loading 101349 client objects. Took 363346.385ms
    3. 10-06-17 08:49:37.489 I: Loading players...
    4. 10-06-17 08:49:37.499 I: Finished loading 0 players. Took 6.822ms
    5. 10-06-17 08:49:37.663 I: Loading spawners...
    6. 10-06-17 08:49:38.903 E: Null Chunk! Location: (-5

    Finished loading 0 players - Does the 'holocore' account not count in this count?

    Sercer Start complete.

    PSWG Launcher also indicates "Server Status UP"

    Clicks Play.

    Game says "connecting to the login server" (eternally)

    Server console reports nothing other than "Started. Time 507959.089ms"



    Does it matter where the core SWG files come from for my client?

    I ask because... I notice it scans the directory so I would believe it doesn't matter, the launcher would detect an issue..?

    But for the record I DO use an end-game installation of SWG. Literally, the last day on the server I copied and archived my complete install folder. It is the same folder I use for ALL other projects (SWGEmu, Stella Bellum, AnnoSwg when it existed, and three or four other NGE-era server projects that have come and gone). I use a fresh "end-game" folder for each, so no other server projects have 'contaminated' the game folder, they are unique to every project.. But they would have all the original .cfg files from Sony the way they were. Never had to edit/change any for any other server, but thought I'd throw it out there in case it might matter for your project.

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

    Edited once, last by exit151 ().

  • the odb files not being loaded is fine.

    you havent created any characters so far so it cant load players


    it should work because your launcher shows that it is connected to it

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • You replied while I was editing my post, but I added this at the bottom in case it matters:

    Does it matter where the core SWG files come from for my client?

    I ask because... I notice it scans the directory so I would believe it doesn't matter, the launcher would detect an issue..?

    But
    for the record I DO use an end-game installation of SWG. Literally,
    the last day on the server I copied and archived my complete install
    folder. It is the same folder I use for ALL other projects (SWGEmu,
    Stella Bellum, AnnoSwg when it existed, and three or four other NGE-era
    server projects that have come and gone). I use a fresh "end-game"
    folder for each, so no other server projects have 'contaminated' the
    game folder, they are unique to every project.. But they would have all
    the original .cfg files from Sony the way they were. Never had to
    edit/change any for any other server, but thought I'd throw it out there
    in case it might matter for your project.

    Hey there new players! First thing you're going to want to do is look at these handy posts/guides. They will help solve a TON of potential issues and problems getting running, whether you're starting your own server up, installing and running the client to PLAY on a server, or just get connected to the PSWG Test server!

    PSWG Launcher Installation Guide 2.0 (not by me but excellent!)

  • as long as you have a fresh swg install on your pc ... and use it as "source" for your PSWG installation ... it should be fine.

    if it would be wrong ... you shouldnt be able to start the game via launcher

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • try to install your PSWG launcher in a different folder than the program files one.

    afaik it sometimes causes problems in windows 10

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK