FIXED JAVA LAUNCHER (temp solution)

    • Helpful

    My ProjectSWG launcher.exe is located in my C:\users\username\App
    Data\local\ProjectSWG folder which was hidden so I had to make is visible. When
    I run the launcher as admin it shows ver 1.2.2.
    Got a new download of the .jar and copied it to that folder and ran the
    .jar with my jre-9.0.4 javaw.exe. The .jar ran it created the .jar.part file and
    the last message was to Restart the launcher to complete. Ran the launcher
    again. It showed the update box and I thought this may have done it but after
    the update ran I hit the play and still loops thru “connecting to logon
    server---socket closed—server is not available at this time. In my download folder I have ProjectSWG-launcher.exe from 3/9/17. So I renamed the App Data
    folder ProjectSWG to ProjectSWG_1.2.2 and ran the launcher from march, it
    installed a new folder in App Data\local\ProjectSWG and the last message was
    please wait while we update the launcher.
    When I run this ProjectSWG launcher.exe as admin I see ver 1.4.0 but the
    play button is not functional the settings are correct and the scan has no
    issues. So I closed it and copied the
    .jar into this folder and ran it. It did create the .jar.part and said Restart launcher to complete. So I closed it and deleted the .jar file, renamed the .jar.part to just .jar and ran it. Even though I got
    the message …”failed download…” the launcher opened showing ver 1.4.0 and hit
    the play button and was able to log in. Who new maybe this might help folks having the
    same issue good luck

  • I'm experiencing the same issue with the download failing each time the launcher is started. This happens on Windows because the launcher can't replace itself with a newer version while it's running.

  • I keep getting "Please restart the launcher to complete the update"

    I ran into both of these issue last night when update the launch from 0.97 to 1.40.

    Create a new file named "ProjectSWG" in "Programs Files (x86)", then place the ProjectSWG.jar inside it before you click to activate the ProjectSWG.jar. Note you will need to delete your old "ProjectSWG" file if updating the launcher from 0.97 verison.

    Ok, after some more investigation. I found out the problem is a bit more complex, but I came across a solution that might help to fix this issue.

    1. Create a new folder called "ProjectSWG".

    2. Download the ProjectSWG.jar.

    3. Place the ProjectSWG.jar into the "ProjectSWG" Folder

    4. Run the ProjectSWG.jar.

    5. A ProjectSWG.jar.part file will appear.

    6. Create a .txt file called "ProjectSWG.txt"

    7. Rename the .txt file to "ProjectSWG.bat"

    8. A dialog box will pop-up ask whether you want to change the file type. Hit "Yes".

    9. When you do this, the icon of the text file will change. If it doesn't, then repeat steps 7 - 8 until it does.

    10. Right Click "ProjectSWG.bat" and select "edit",

    11. A text box will appear. Write this "java -jar ProjectSWG.jar.part" without the quotes.

    12. Hit "save"

    13. Close the text box.

    14. Run "ProjectSWG.bat"

    If everything works right, you should get to the ProjectSWG launcher.

    Disclaimer: Again, this fix worked for me, but it might not work for everyone.


    Characters: Elmirea Runningstrider, Omarri
    Server: Bria
    Guild: Mansurus Ordo
    Years: 2007-2010

  • I can get the launcher to start, but the session does not start. The little world moves to the bottom of the window, and then goes red.

    I copied this from the log in c:\user\<username>\appdata\roaming\.projectswg\launcher.


    19-03-18 16:30:19.217 I: Main button PLAY pressed

    19-03-18 16:30:19.224 I: Launching SWG

    19-03-18 16:30:19.226 D: Launching 'C:\Users\pcgoblin\AppData\Roaming\.projectswg\launcher\GameLauncher.jar'...

    19-03-18 16:30:19.238 I: Launching game!

    19-03-18 16:30:19.618 I: Loading fxml: C:\Users\pcgoblin\AppData\Roaming\.projectswg\launcher\res\ProjectSWG\fxml\Game.fxml

    19-03-18 16:30:19.619 D: Set Status: game_started

    19-03-18 16:30:19.622 I: Game Launched! Token: LRN1tTUOisWR8Tq6FPMecScqb33WO95E

    19-03-18 16:30:19.623 D: Set Status: game_running

    19-03-18 16:30:20.718 D: Set Status: game_over

    19-03-18 16:30:24.540 I: Terminating FXML controllers

    19-03-18 16:30:24.542 I: Saving preferences

    19-03-18 16:30:24.548 I: Launcher stopped

    19-03-18 16:30:24.556 W: Active Threads: 8

    19-03-18 16:30:24.557 W: +-------------------------------------------+

    19-03-18 16:30:24.558 W: | Name | State |

    19-03-18 16:30:24.559 W: +---------------------------+---------------+

    19-03-18 16:30:24.560 W: | main | WAITING |

    19-03-18 16:30:24.561 W: | QuantumRenderer-0 | WAITING |

    19-03-18 16:30:24.562 W: | Thread-1 | WAITING |

    19-03-18 16:30:24.563 W: | JavaFX Application Thread | RUNNABLE |

    19-03-18 16:30:24.564 W: | JavaFX-Launcher | WAITING |

    19-03-18 16:30:24.565 W: | Thread-3 | RUNNABLE |

    19-03-18 16:30:24.566 W: | Media Resource Disposer | WAITING |

    19-03-18 16:30:24.567 W: | game-processor-1 | WAITING |

    19-03-18 16:30:24.568 W: +-------------------------------------------+

    I do not recall seeing any solutions for this. That's ok though. With PSWG, i am made of patience. That should be more of a simile than metaphor. "This is Pcgoblin. He is made from body parts from cadavers whose names were Patience."

  • Hello all! Regrettably I left the launcher in a rather broken state during my backend Holocore escapade. This is now at the top of my to-fix list.

    The biggest issue that I am aware of is that the launcher will not update on Windows due to file access restrictions. I have a fix for this completed, but to implement it I need some UI changes to notify when a download is available and to allow updating.

    In addition, launching/terminating the game isn't working very well. This requires a critical look at the process that manages communication with the SWG Client process to ensure it always acts in a safe way, and properly reports any errors that occur.

    My aim is to be done with these updates by 26 March. In the meantime, an updated JAR file is available here, which I have been using to do development locally. I hope it works for you until a proper fix is sent out.