Setting up localhost

  • Hello all,


    When Project SWG updated the core from NGECore2 to the Holocore, I decided to wait awhile before digging back into it and learining what I could about the core code. Now i have attempted to follow the instructions on the bitbucket site, but it isn't very helpful. I need a wee bit of help making sure I did everything right, and seeing why I can't connect Localhost. If anyone has it runnig on their computer, i would appreciate the assist.


    To help you out, I am currently running a Win 7 32-bit PC, using pgAdmin as my VM Database Server, my java is current, I have Maven installed and pathed, I have a valid SWG install, I extracted all of the files the in the list on the site (though it took forever, because TRE Explorer seems to be broken), and I did the nge.backup restore (and it gives me exit code 1 with 12 errors ignored).


    I've looked all over the net and this forum and no one has any tutorials, explanations, or help of any kind associated to the Holocore. I find that a bit disappointing that there is no help any where out there. I found 1 video on Vimeo, but it was only a small part of the process, has no sound, and explains nothing.

  • There has been a tutorial in the works, but hasn't been finalized yet. We will renew efforts into completing it this week.


    In the meantime, anyone having issues getting things to work feel free to PM me and I will help you set it all up.

  • Thanks for the reply. I'll give you all some time to get a tutorial up. I got lots of time, too much in fact. Getting bored. I need to sink my teeth into some code soon before I forget how. But I ain't gonna pressure anyone. I got a few things to keep me occupied until then. if I don't see anything this week, I might send a PM, but i rather leave you to it and wait for an official guide (preferably with a video guide to assist). thanks for keeping the project alive.