Launching Server

  • Ah, just tried to connect: Connection refused. I see why it was saying client/server offline. As you stated in a guide, it uses the client... so I need to connect in order to update those. Got that. Just getting connection refused now. login server is currently unavailable

  • so 1st start the fowarder.jar
    leave it open (shows all offline first)


    then run eclipse and the server


    once you login with your details the forwarder.jar will establish a connection and show ONLINE

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • Okay, closed everything. Opened forwarder. Opened eclipse: Run config > run with the parameters in the guide.
    Launched pgAdmin III, signed in. Checked nge database for users and galaxies settings: They're as the guide was.
    Launched projectswg. It launched a TRE file repair tool. It's about 1/2 way through the process.


    If you're willing, and you can, I can jump on comms if it'd make it easier?

  • Now to figure out how to get her connected (same LAN all wired) lol. I'll try not to bother you with this... I hope.

  • Thank you all so very kindly! Really appreciate it! I see that now. I'm just such a nub when it comes to this stuff. Really really appreciate all your help and support. I'm going to keep coming here and donating to your guys' efforts to re-build the galaxy. Your support has really blown my wife and I, away. Kudos.

  • Hi all!


    I've got this error while running Eclipse with Maven Build:



    java.nio.BufferUnderflowException
    at java.nio.ByteBuffer.get(Unknown Source)
    at java.nio.DirectByteBuffer.get(Unknown Source)
    at java.nio.ByteBuffer.get(Unknown Source)
    at resources.client_info.SWGFile.isValidIff(SWGFile.java:106)
    at resources.client_info.SWGFile.read(SWGFile.java:88)
    at resources.client_info.DataFactory.readFile(DataFactory.java:52)
    at resources.client_info.ClientFactory.getInfoFromFile(ClientFactory.java:92)
    at resources.client_info.ClientFactory.getInfoFromFile(ClientFactory.java:118)
    at services.objects.ClientBuildoutService.<init>(ClientBuildoutService.java:46)
    at services.objects.ObjectManager.<init>(ObjectManager.java:80)
    at services.galaxy.GalacticManager.<init>(GalacticManager.java:55)
    at services.CoreManager.<init>(CoreManager.java:85)
    at main.ProjectSWG.run(ProjectSWG.java:93)
    at main.ProjectSWG.main(ProjectSWG.java:53)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.codehaus.mojo.exec.ExecJavaMojo$1.run(ExecJavaMojo.java:293)
    at java.lang.Thread.run(Unknown Source)
    ProjectSWG: Shutting down - unknown error.
    ProjectSWG: Server shut down.



    I don't know what i did wrong.

  • Seems like it's not loading the misc/object_template_crc_string_table.iff file correctly in your clientdata/misc folder (though I could be wrong). Do you mind posting a screenshot of whats in that folder?


  • This is a rather unique error.. I haven't seen it before. However if I had to guess I'd say that's probably due to invalid exporting (or not at all) of clientdata.

  • But i don't know why couldn't i export normally. I downloaded the sku0_client.toc via the launcher.

    thats about our old Core2 code but the procedure to extract the files is the exact same


    jump to 11:52


    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • Thnak you very much, i tried it. But i got the same error. I'm sure that i'm making something wrong but i don't know what.

    make a screenshot of your main folder and put it in here (drag & drop)

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK

  • looks good so far


    and in your clientdata folder you have all the sub folders too ?
    but i guess so when you downloaded and extracted obi his file

    Ph2zuj0.png

    Characters: Bipolei (Officer) /// Undercova Brother (Medic)
    Server: Europe - Infinity /// Europe - Farstar /// Europe - Chimaera
    Guild:
    HAWK